Mac 下切換多版本的 PHP: php-version

如果你用 PHP 開發程式,一定會遇過有些 legacy 的專案需要 PHP 5.6 甚至 5.3,但新的專案卻希望走在時代的尖端,使用 PHP 7 以上的版本。這邊就來說明一下,要怎麼快速地切換 PHP 環境。 前提 你的 PHP 得是用 Homebrew 裝的,但我相信今時今日應該大家起手式都是 brew install 了吧。 裝兩個版本的 PHP 先裝 php71 $ brew install php71 $ php -v PHP 7.1.12 (cli) (built: Dec 2 2017 12:…